麦乐学园

返回列表
查看: 36|回复: 1

置入代码装逼系列之-整除,求余

[复制链接]
发表于 6 天前 | 显示全部楼层 |阅读模式
分享源码
源码截图:
是应该叫装逼系列呢 还是叫脱裤子放P系列呢....
.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 a, 整数型
.局部变量 b, 整数型

a = 5002
b = 123
调试输出 (汇编_整除 (a, b))
调试输出 (汇编_求余 (a, b))

.子程序 汇编_整除, 整数型, , 除数为0时返回 -1
.参数 被除数, 整数型
.参数 除数, 整数型

置入代码 ({ 102, 139, 77, 12, 103, 227, 11, 139, 69, 8, 139, 77, 12, 153, 247, 241, 201, 195, 201, 184, 255, 255, 255, 255, 194, 4, 0 })
' mov cx,[ebp+12]
' jcxz demo
' mov eax,[ebp+8]
' mov ecx,[ebp+12]
' cdq
' div ecx
' leave
' ret
' demo:
' leave
' mov eax,-1
' ret 4
返回 (0)

.子程序 汇编_求余, 整数型, , 除数为0时返回 -1
.参数 被除数, 整数型
.参数 除数, 整数型

置入代码 ({ 102, 139, 77, 12, 103, 227, 13, 139, 69, 8, 139, 77, 12, 153, 247, 241, 137, 208, 201, 195, 201, 184, 255, 255, 255, 255, 194, 4, 0 })
' mov cx,[ebp+12]
' jcxz demo
' mov eax,[ebp+8]
' mov ecx,[ebp+12]
' cdq
' div ecx
' mov eax,edx
' leave
' ret
' demo:
' leave
' mov eax,-1
' ret 4
返回 (0)







回复

使用道具 举报

发表于 6 天前 | 显示全部楼层
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

Archiver|手机版|小黑屋| MLG8.CC

Copyright © 2015-2016 Comsenz Inc.   All Rights Reserved.

Powered by Discuz! X3.2( 宁ICP备16002180号 )

快速
回复
返回
列表
返回
顶部